Entrar     Registrar  
 
 
De Tudo um Pouco
 
 
Colunas
 
 
Fale conosco
 
 

 

 

 
 Pequenas doações são suficientes para fazer grandes projetos ou manter vivas algumas ideias.
Da forma que você puder, e quiser, ajude-nos a manter o De Tudo Um Pouco no ar.
  ColunasDesenvolvimentoC# e coisas mais    março 29, 2017
Minimizar
02

Resumo: Uso das função SE()
Grau de dificuldade: baixo
Requisitos : Conhecer operações lógicas e relacionais.

O objetivo é elucidar o uso da função Se(), cuja sintaxe é SE(<condição lógica>;<opção verdade>;<opção falsa>). Na condição lógica far-se-á as operações relacionais e operações lógicas, caso o resultado dessa condição lógica seja verdadeiras a opção verdadeira é executada e, de outra forma, a opção falsa é executada.

Assim, vê-se em nossa tabela que há dias de pagamento que são dias de final de semana, como na figura abaixo:

Antes de incluir a seleção na planilha, inclua a coluna data e faça as seguintes alterações, conforme as fórmulas da figura abaixo:

A aparência dos dados deve se a abaixo:

 

Primeiramente, vamos construir uma fórmula para, quando domingo, acrescer um dia à data do pagamento. Para saber-se o dia da semana ter-se-á de usar a seguinte fórmula: DIA.DA.SEMANA(), que utilizamos da vez anterior. Essa função trará o número 1, se for domingo e, assim, deve-se fazer:

Se o dia da semana = 1

acrescentar 1 dia

senão

aceitar a data estabelecida

fim

Vamos incluir esta seleção à coluna E, que contém a seguinte fórmula no momento:=$B$4+D2*30. Vamos alterar para

=SE(DIA.DA.SEMANA($B$4+D2*30)=1;($B$4+D2*30)+1;($B$4+D2*30))

         +------------------------------------------+------------------------+------------------+

                               Condição                        val. Verdadeiro         val. Falso

Ora, se for sábado, basta substituir a condição por DIA.DA.SEMANA($B$4+D2*30)=7 e, dessa forma, deve-se testar as duas possibilidades, sendo que sendo sábado, acrescenta-se dois dias à data do pagamento, ficando assim:

=SE(DIA.DA.SEMANA($B$4+D2*30)=1;($B$4+D2*30)+1;SE(DIA.DA.SEMANA($B$4+D2*30)=7;($B$4+D2*30)+2;($B$4+D2*30)))

                                                                                                            +--------------------------------------------+----------------------+------------------+

                                                                                                                                   Condição                        val. Verdadeiro         val. Falso

        +------------------------------------------+------------------------+------------------------------------------------------------------------------------------------+

                               Condição                        val. Verdadeiro                                                                      val. Falso

Temos, então, duas seleções aninhadas. Podem ser acrescentadas outras tantas, mas, ressalva-se que a legibilidade fica prejudicada!. As fórmulas apresentam-se então:

 

E a  Planilha final:

Comentários

Atualmente não há comentários. Seja o primeiro a colocar um.

Postar comentário

Somente usuários registrados podem postar comentários.
 
  Copyright 2003-2017 - Ronaldo C. E. Santos   Termos de uso  Privacidade